Search found 60 matches

by Vyper68
Tue May 14, 2019 12:26 pm
Forum: Emulators
Topic: Oricutron and illegal opcode 80
Replies: 35
Views: 653

Re: Oricutron and illegal opcode 80

Here are some pictures of my Atmos for you to look at, the Transistor is a BC237 i think as it says C237. Looking at the 65c02 i think it was fitted later as the date code is 8813 so it's not factory fitted. https://i.ibb.co/VDCz1s7/P1010321.jpg https://i.ibb.co/fDdHqYv/P1010325.jpg https://i.ibb.co...
by Vyper68
Mon May 13, 2019 7:34 pm
Forum: Emulators
Topic: Oricutron and illegal opcode 80
Replies: 35
Views: 653

Re: Oricutron and illegal opcode 80

Would anyone be able to make another .tap file of Harrier Attack with the illegal Op Code amended? I have a French Atmos that seems to have a factory fitted 65c02P4 and it freezes after loading the first part of the Atmos tape file and it has been suggested that this Op Code is the cause of this. It...
by Vyper68
Sun Apr 28, 2019 3:15 pm
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

Thanks Chema just bought one :D
by Vyper68
Sun Apr 28, 2019 1:34 pm
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

Yes it is frustrating, given how many logic chips have been damaged and the ULA and ROM don't work having tried them in my Atmos seperately I don't hold out much hope for the other IC's. That said, I picked up an old Oceanic 118n 5.25" Floppy drive to pull the 6502 and 6522's out and I have a workin...
by Vyper68
Tue Apr 23, 2019 12:07 pm
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

I think I will have to write this one off as a bad job, the ULA is toast and so is the ROM so I am not going to spend more time on this one.
by Vyper68
Mon Apr 22, 2019 9:36 am
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

Thanks for the help mikeb you are a star! That will help greatly. It does seem like the clock is there now but I have a horrible feeling the ULA and main IC's have been damaged by whatever event occured. Still it won't put me off, I have a AY chip, 6502, 6522 and RAM, I can burn a new ROM and I will...
by Vyper68
Sun Apr 21, 2019 8:19 am
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

I had some more duff logic chips .... I have not got it working yet sadly as there now seems to be no Clock signal from the 12Mhz crystal or IC21 is stuffed as well. I am starting to think that someone plugged a PSU socket in the modulator or something equally as odd. OK, it's quite unlikely that a...
by Vyper68
Sat Apr 13, 2019 7:31 am
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

I had some more duff logic chips on the UHF modulator circuit the other LS74 and LS04. I have not got it working yet sadly as there now seems to be no Clock signal from the 12Mhz crystal or IC21 is stuffed as well. I am starting to think that someone plugged a PSU socket in the modulator or somethin...
by Vyper68
Tue Apr 09, 2019 6:04 pm
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Re: Oric-1 Repair

Thanks for the replies guys, helpful advice. Yeah, I have no info on the Oric's history other than it was a non-runner and bought or donated to my friend as such. So what happened I do not know. It was never opened since it was sold as the Seal was intact and untampered until I lifted it off. I was ...
by Vyper68
Tue Apr 09, 2019 10:00 am
Forum: Technical questions
Topic: Oric-1 Repair
Replies: 36
Views: 1329

Oric-1 Repair

Hi I have been repairing an Oric-1 for a friend this week and have made some progress. I had to fit a new 7905 and once I did I was getting a reading of 3.5V so something was pulling it low. I went for the RAM at first but rather than cut the traces on the 0V Rail I desoldered them one at a time ( l...
by Vyper68
Thu Aug 09, 2018 3:19 pm
Forum: Technical questions
Topic: Oric Atmos Boot-Up Query
Replies: 10
Views: 3328

Re: Oric Atmos Boot-Up Query

I have 8 Atmos, an Oric-1 and a Telestrat - and they all behave differently depending on the power supply being used. I've noticed that the lower Amps, the messier the screen on boot up - maybe this is a clue? I am using a decent 9V 1A PSU what are you using for your Oric's & Telestrat ( nice :D )
by Vyper68
Thu Aug 09, 2018 4:34 am
Forum: Mags and books
Topic: Oric Atmos Manual Wanted
Replies: 8
Views: 1986

Re: Oric Atmos Manual Wanted

Steve M wrote:
Thu Aug 02, 2018 1:28 pm
I should be able to find one for you.
Thanks Mate you're a good'un :D
by Vyper68
Sat Jul 28, 2018 4:33 pm
Forum: Technical questions
Topic: Oric Atmos Boot-Up Query
Replies: 10
Views: 3328

Re: Oric Atmos Boot-Up Query

iss wrote:
Sat Jul 28, 2018 10:12 am
You're not alone! :)
And I think I have one more Atmos with the same issue.
I don't know why this really happens, but it's interesting for investigation.

I get the same character as you most of the time - this is very odd.
by Vyper68
Sat Jul 28, 2018 4:31 pm
Forum: Technical questions
Topic: Oric Atmos Boot-Up Query
Replies: 10
Views: 3328

Re: Oric Atmos Boot-Up Query

Well my Atmos has 8 4164 stylye RAM Chips.

Image
by Vyper68
Thu Jul 26, 2018 12:50 pm
Forum: Technical questions
Topic: Oric Atmos Boot-Up Query
Replies: 10
Views: 3328

Re: Oric Atmos Boot-Up Query

This one has a multi-coloured block random pattern a bit like the ZX Spectrum then it goes to a page of black & white vertical lines and then the Oric welcome screen ( plus "{" 90% of the time ). It does seem to take a bit longer to boot than my old Atmos ( unless my mind is playing tricks on me ). ...